Sign up for our newsletter
Technology / Hardware

WordPress Update: Radical 5.0 Release Comes with Warnings

WordPress has released the biggest change to its editor in 15 years. With close to a third of the world’s websites built on the publisher, this is a big deal.

Today, WordPress is built on PHP and MySQL, and open source licensed under GPLv2. The platform underpins over 32 percent of all sites across the web.

Yet many users have warned that the December 6 WordPress update (communicated to the WordPress community just two days earlier) is not as stable as it should be, despite a positive user experience and urged a delay in updating until bugs are ironed out.

New editor Gutenberg may also take some getting used to: it has been described as representing  “a fundamental shift in the WordPress editing experience” and uses a new drag and drop block structures to simply adding rich media.

White papers from our partners

Those blocks can be anything from videos to source code blocks or audio players. Project lead Matt Mullenweg explained the shift: “The classic Editor was built primarily for text — articles have become increasingly multimedia, with social media embeds, maps, contact forms, photo collages, videos, and GIFs. It was time for a design paradigm that allowed us to move past the messy patchwork of shortcodes and text.”

From a website design perspective, initial feedback has been largely positive.

Fabio Torlini, Managing Director, EMEA at WP Engine, a WordPress services company, is excited. He told Computer Business Review: “Businesses are about to witness a truly seismic change. We will see the rise of newer, better digital experiences that support all the new media, video and social channels that are quickly dominating the web…”

He added: “Where WordPress provided a revolutionary open source solution for website creation, Gutenberg truly democratises the web.”

wordpress upgrade
Some of the blocks available in Gutenberg

WordPress Update: Plugin Warnings

But other users have some warnings and they may alarm users.

Mark Maunder, CEO of Defiant Inc., which trades as security plug Wordfence: “With over 60,000 unique plugins in the WordPress plugin directory, it is not feasible to test all of the plugins with the new editor. Actively maintained plugins are, for the most part, being tested by the plugin authors. Abandoned plugins will not have been tested, so it is up to you to test whether WordPress 5.0 will work with these plugins.”

He added: “Some WordPress site owners may be unable to effectively edit pages they had previously published. Some may be unable to access their edit screen. There may be server 500 errors or white screens for some users. Or everything may run smoothly, even with legacy plugins and a legacy theme.”

Yoast SEO, which provides an SEO optimising plugin, also sounded a cautionary note: “If there is no compelling reason for you to update, our suggestion is going to be: wait. WordPress 5.0 will probably be more stable in January than it is now. Yoast SEO is ready [but] we don’t think WordPress 5.0 is as stable as it should be.

“Our advice boils down to: if you can wait, wait.When you upgrade, please, as always: make a backup. If you have a staging environment, please use it. If you don’t have one, and your site is critical to your business, get one. This goes for every major software release though, not just this one.”

See also: Smart Data and Visibility for Greater Application Security: The DevSecOps Opportunity

 


This article is from the CBROnline archive: some formatting and images may not be present.

CBR Staff Writer

CBR Online legacy content.